gillesss | C'est pas très claire tous ca, un les confs sont pas complete.
en tous cas j'ai reproduit ca en modifier juste l'AS pour ASBR_D2, ce qui parait beaucoup plus logique que d'utiliser le meme AS pour 2 peer BGP.
D'abord un schema recapitulatif ca aide a mieux visualiser :
Ensuite les conf completes, ATTENTION les interfaces sont differentes dans mon cas:
R_BACKBONE_D1
Code :
- version 12.4
- service timestamps debug datetime msec
- service timestamps log datetime msec
- no service password-encryption
- !
- hostname R_Backbone_D1
- !
- boot-start-marker
- boot-end-marker
- !
- no aaa new-model
- ip cef
- !
- ipv6 unicast-routing
- ipv6 cef
- !
- multilink bundle-name authenticated
- !
- interface GigabitEthernet1/0
- no ip address
- negotiation auto
- ipv6 address 2001:DB8:2:2::1/64
- ipv6 ospf 10 area 0
- !
- no ip http server
- no ip http secure-server
- !
- ipv6 router ospf 10
- router-id 1.1.1.1
- log-adjacency-changes
- !
- end
|
R_ASBR_D1
Code :
- version 12.4
- service timestamps debug datetime msec
- service timestamps log datetime msec
- no service password-encryption
- !
- hostname R_ASBR_D1
- !
- boot-start-marker
- boot-end-marker
- !
- no aaa new-model
- ip cef
- !
- ipv6 unicast-routing
- ipv6 cef
- !
- interface GigabitEthernet1/0
- no ip address
- negotiation auto
- ipv6 address 2001:DB8:2:2::2/64
- ipv6 ospf 10 area 0
- !
- interface GigabitEthernet2/0
- no ip address
- negotiation auto
- ipv6 address 2001:DB8:6:1::1/64
- ipv6 enable
- !
- router bgp 100
- bgp router-id 1.1.1.2
- no bgp default ipv4-unicast
- bgp log-neighbor-changes
- neighbor 2001:DB8:6:1::2 remote-as 200
- !
- address-family ipv6
- neighbor 2001:DB8:6:1::2 activate
- redistribute connected
- redistribute ospf 10
- no synchronization
- exit-address-family
- !
- ipv6 router ospf 10
- router-id 1.1.1.2
- log-adjacency-changes
- redistribute bgp 100
- !
- end
|
R_ASBR_R2
Code :
- version 12.4
- service timestamps debug datetime msec
- service timestamps log datetime msec
- no service password-encryption
- !
- hostname R_ASBR_D2
- !
- boot-start-marker
- boot-end-marker
- !
- no aaa new-model
- ip cef
- !
- ipv6 unicast-routing
- !
- interface GigabitEthernet1/0
- no ip address
- negotiation auto
- ipv6 address 2001:DB8:6:1::2/64
- !
- interface GigabitEthernet2/0
- no ip address
- negotiation auto
- ipv6 address 2001:DB8:4:2::2/64
- ipv6 ospf 10 area 0
- !
- router bgp 200
- bgp router-id 2.1.1.2
- no bgp default ipv4-unicast
- bgp log-neighbor-changes
- neighbor 2001:DB8:6:1::1 remote-as 100
- !
- address-family ipv6
- neighbor 2001:DB8:6:1::1 activate
- redistribute connected
- redistribute ospf 10
- no synchronization
- exit-address-family
- !
- ipv6 router ospf 10
- router-id 2.1.1.2
- log-adjacency-changes
- redistribute bgp 200
- !
- end
|
R_BACKBONE_D2
Code :
- version 12.4
- service timestamps debug datetime msec
- service timestamps log datetime msec
- no service password-encryption
- !
- hostname R_Backbone_D2
- !
- boot-start-marker
- boot-end-marker
- !
- !
- no aaa new-model
- ip cef
- !
- ipv6 unicast-routing
- !
- interface GigabitEthernet1/0
- no ip address
- negotiation auto
- ipv6 address 2001:DB8:4:2::1/64
- ipv6 ospf 10 area 0
- !
- ipv6 router ospf 10
- router-id 2.1.1.1
- log-adjacency-changes
- !
- end
|
Petite vérification de la table de routage de R_BCK_D1 :
Code :
- R_Backbone_D1#sh ipv6 route
- IPv6 Routing Table - 4 entries
- Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
- U - Per-user Static route, M - MIPv6
- I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
- O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
- ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
- D - EIGRP, EX - EIGRP external
- C 2001:DB8:2:2::/64 [0/0]
- via ::, GigabitEthernet1/0
- L 2001:DB8:2:2::1/128 [0/0]
- via ::, GigabitEthernet1/0
- OE2 2001:DB8:4:2::/64 [110/1]
- via FE80::C805:34FF:FE12:1C, GigabitEthernet1/0
- L FF00::/8 [0/0]
- via ::, Null0
- R_Backbone_D1#
|
Et d'un ping de R_BCK_D1 vers R_BCK_D2:
Code :
- R_Backbone_D1#ping ipv6 2001:DB8:2:2::1
- Type escape sequence to abort.
- Sending 5, 100-byte ICMP Echos to 2001:DB8:2:2::1, timeout is 2 seconds:
- !!!!!
- Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/4 ms
|
Sinon plutot que d'utiliser une redistribution, pourquoi ne pas simplement utiliser la commande network dans BGP ? Redistribuer prend tout son sens s'il y a plusieurs reseau. |